読者です 読者をやめる 読者になる 読者になる

初めてのシステムと日記

システムも日記も初めてです。

安定版以外のパッケージインストール

PHP PEAR

先日試したImage_3Dをインストールしようとしたら下記のようなエラーが発生。

# pear install Image_3D
Failed to download pear/Image_3D within preferred state "stable", 
latest release is version 0.4.1, stability "alpha", use "channel://pear.php.net/Image_3D-0.4.1" to install
install failed


このエラーの原因は、PEARのデフォルト設定で安定版(stable)のみパッケージインストールできるようにしているためです。
開発版(devel)、アルファ版(alpha)、ベータ版(beta)のパッケージをインストールしようとすると拒否されます。
これらをインストールしたい場合は、下記のようにバージョン番号を指定。

# pear install Image_3D-0.4.1
downloading Image_3D-0.4.1.tgz ...
Starting to download Image_3D-0.4.1.tgz (132,467 bytes)
.............................done: 132,467 bytes
install ok: channel://pear.php.net/Image_3D-0.4.1


参照URL
http://pear.php.net/manual/ja/guide.users.commandline.installing.php
※最先端を行くがちょっとツボでしたw